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LAB 20 - Constructing A Driveway

Driveway modeling should not be done to the level of detail that mainline corridor modeling is done.  
However, there may be times when a drive should be modeled accurately.  This lab describes a workflow for 
modeling driveways quickly and easily.

Chapter Objectives:  This lab models a driveway from the proposed edge of pavement of the design 
corridor to the existing ground at the right of way line.  The following InRoads tools are used to 
complete the model:

 Use Tracking to determine the location of the ramp.

 Use Generate Longitudinal Feature to construct the centerline and edge features of the 
ramp.

 Use Drape Surface to create the end of the drive.

 Use Import Surface to create features from MicroStation graphics.

 Use Fillet Feature to construct the drive returns.

 Use Join Features to create a continous feature from the driveway edges and returns.

 Use Apply Template create sideslopes for the driveway.

The following files are used for this lab:

 C:\Projects\12345\ROW_Survey\InRoads\DTM\12345 existing ground.dtm

 C:\Projects\12345\Design\InRoads\SH86.dtm

 C:\Projects\12345\Design\InRoads\12345DES_Geometry.alg

 C:\Projects\12345\Design\InRoads\DES12345_Templates.itl

The driveway is 12’ wide extending from the proposed edge of pavement to the right of way, 60’ to the right of 
the SH 86 centerline.  The driveway returns have a 15’ radius.  There is a 12:1 slope for 20’ from the edge of 
pavement.  

Lab 20.1 - Locating The Driveway

The new driveway is located on top of the existing driveway between stations 254+00 and 255+00 or the right 
side of the mainline.

Section Objectives:

 Use Tracking to determine the centerline station of the driveway.

 Use MicroStation key-ins to construct a line for the driveway centerline and end line.

1. Open InRoads using the 12345DES_Driveway.dgn file.

Note: If the existing drive is not visible, display the driveway saved view.  To display a 
saved view:

a. <D> the icon in the left corner of the view title bar and select View Save/Recall.

b. In the Saved Views dialog box, highlignt driveway.
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c. <D> Apply and then <D> Close to dismiss the Saved Views dialog box.

2. Open the following InRoads data files:

♦ C:\Projects\12345\ROW_Survey\InRoads\DTM\12345 existing ground.dtm

♦ C:\Projects\12345\Design\InRoads\SH86.dtm

♦ C:\Projects\12345\Design\InRoads\12345DES_Geometry.alg

♦ C:\Projects\12345\Design\InRoads\DES12345_Templates.itl

3. Verify that the C:\Workspace\Workspace-CDOT_XM\Standards-Global\ 
InRoads\Preferences\CDOT_Civil.xin file is loaded.

4. Verify that the SH 86 alignment is active.

5. Select Tools > Tracking > Tracking from the InRoads menu bar.
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6. Activate the tracking and <T> to the center of the back of the driveway.

7. Write down the Station listed in the Tracking dialog box.

8. From the CDOT Menu, highlight the Geometry group.

9. <D> the Other button and select Alignment from the item list.



Page 380 Colorado Department of Transportation

LAB 20 - Constructing A Driveway Labs for InRoads XM

10. In the MicroStation key-in window, type so=254+47.15,0 and Enter.

Note: Use the station that you wrote down in step 6.

11. Key in so=254+47.15,60 and Enter.  <R> to end the line.

This places a line at the centerline of the driveway.  This line is used as a reference line when 
constructing the driveway surface features.

12. Key in so=254+41.15,60 and Enter. 

13. Key in so=254+53.15,60 and Enter.  <R> to end the line.

Note: Use stations 6’ before and 6’ after the one you wrote down in step 6.

This places a 12’ long line at the end of the driveway representing the width of the drive.  This 
line is also used as a reference line when constructing the driveway surface features.

Section Summary:

The location of the driveway was identified and elements needed to create the driveway 
centerline and end line were placed.

Lab 20.2 - Setting Elevations

In this section, the driveway end line is draped to the existing surface to aquire the elevations for that feature.  
The line for the driveway centerline is moved to the proper elevation, then is modified to give it the proper 
slopes.
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Section Objectives:

 Create a surface for the driveway.

 Use Drape Surface to create the driveway end line feature.

 Display the design surface (SH 86) triangulated features.

 Move the driveway centerline to its proper location (horizontally and vertically.

 Create a centerline feature with the proper slopes using Generate Longitudinal Feature and 
Edit Feature Point.

1. Select File > New from the InRoads menu bar.

2. On the Surface tab, set the Type to Design.

3. In the Name field, key in Driveway 254+47.15 Rt.

4. In the Description field, key in Driveway at station 254+47.15 on the right.

5. Set the Preference to Proposed and <D> Apply then Close.

6. From the InRoads menu bar, select Surface > Design Surface > Drape Surface.

7. Set the Destination Surface to 12345 existing ground.

8. Set the Input Mode to Single.

9. Set the Destination Level to DES_SURFACE _1.

10. Toggle on Delete Original Graphics.
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11. <D> Apply then follow the prompts in the MicroStation message window (lower left 
corner of the screen).

12. Close the Drape Surface dialog box.

This creates a MicroStation graphic element that matches the elevations of the existing ground.  
Next that element is imported into the Driveway 254+47.15 Rt surface.

13. Select File > Import > Surface from the InRoads menu bar.

14. In the Import Surface dialog box, set the Surface to Driveway 254+47.15 Rt.

15.  Set Load From to Single Element.

16. Set Elevations to Use Element Elevations.

17. In the Seed Name field, key in Driveway_End.
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18. Set the Feature Style and Point Type to Breakline.

19. <D> Apply.

20. <D> the element created by the Drape Surface command.  <D> in a blank area to accept 
the element.

21. Close the Import Surface dialog box.

The driveway end line is now stored as a surface feature.  To place the driveway center line at 
the correct location, the features of the SH86 surface must be displayed.  Use the feature filter 
to display only the triangulated features of the SH86 surface, then move the driveway 
centerline to the proper location.

22. On the InRoads Locks toolbar, set the feature filter to XS_Excluded from 
Triangulation.

23. Toggle on the Feature Filter Lock.

24. Select Surface > View Surface > Features from the InRoads menu bar.

25. Select SH86 for the Surface.
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26. Highlight all of the features in the Features list.

27. <D> Apply then Close the View Features dialog box.

The red line running through the existing driveway is the proposed edge of pavement. The 
driveway centerline needs to be moved to start at this edge line.

28. Use the MicroStation Move command and pick up the driveway centerline, snapping to 
the end on the mainline centerline.



Colorado Department of Transportation   Page 385

Labs for InRoads XM LAB 20 - Constructing A Driveway

29. Snap to the intersection of the driveway centerline and the edge of pavement feature to 
place the line in its new location.  <D> to complete the move then <R> to exit the 
command.

Next, the point of the “breakover” from the 12 to 1 slope must be located.  This point is 20’ 
from the proposed edge of pavement, or 44’ from the mainline centerline.

30. Select the MicroStation Place Smartline command.   

31. In the MicroStation Key-in window, type so=254+00,44 and press Enter.  The starting 
station of this line is not important as it will be deleted once the driveway centerline is 
modified.

32. Key in so=254+47.15,44 and press Enter.  <R> to end the line.
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33. Select Extend Element to Intersection from the MicroStation main toolbar and shorten the 
driveway centerline back to the line just placed.  The illustration below shows the result.

Now the 12 to 1 slope is added to the line.  The Generate Longitudinal Feature command is 
used to create the sloped element.  The Generate Graphic Only option is used because 
additional editing is required.

34. From the InRoads menu bar, select Surface > Design Surface > Generate 
Longitudinal Feature. 

35. On the Main tab of the Generate Longitudinal Feature dialog box, key in 20 for the 
Interval.

36. set the Feature Style to Breakline.
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37. Toggle on Generate Graphic Only.

38. Select the Controls tab.

39. For the Horizontal control, use Offset from Primary Feature with Start and Stop values 
of 0.00.

40. Set the  Vertical control Method to Elevation/Longitudinal Slope.

41. Set the Start Elevation by selecting the “Target” button then <T> to the beginning of the 
driveway centerline, <D> to accept.  The elevation should be around 6545.80.
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42. Key in 1/12 for the Logitudinal Slope.  The result will be 8.33%.

43. <D> Apply, then follow the prompts in the lower left corner of the MicroStation window.  

44. Select the driveway centerline as the primary and reference element.  

45. <R> to use the entire line, the <D> to finish the command.

Be careful in the next steps, because the original line is under the line just created.  This new 
line is modified by adding a vertex, extending it to the driveway end line.

46. Select Insert Vertex form the MicroStation main toolbar.

47. <T> to the end of the new driveway centerline, then <D> to accept.

48. <T> to the center of the driveway end line and <D> to accept.  <R> to exit the command.

49. Delete the original driveway centerline and the reference lane, they are not used to create 
the driveway surface.
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The elevation of the driveway centerline at the edge of pavement was set when the line was 
moved.  The elevation at the end of the initial slope was set using the Generate Longitudunal 
Feature command.  Finally. the elevation at the end of the drive was set by snapping the new 
vertex to the driveway end line created eariler.  The driveway centerline now represents the 
profile of the driveway.

Section Summary:

In this section, the features of the mainline road were displayed as an aid in designing the ramp.  
The driveway end line was draped to the existing ground and stored in the diveway surface.  A 
3D centerline was created with the desired slopes.

Lab 20.3 - Create Driveway Edges

The Driveway centerline is used to define the driveway edge features, then the Fillet Feature command is used 
to create the drive returns.  The driveway edge lines are then joined to the driveway return to create a single 
feature.

Section Objectives:

 Copy the Driveway centerline to form the edge lines.

 Use Import Surface to create surface features from the edge line  graphic elements.

 Use Fillet Feature to create the driveway returns.

 Use Partial Delete on the edge line features to clear the driveway ramp.

 Use Join Feature to create a single feature from the driveway edge line an the return.

1. Select the Copy command from the MicroStation Main toolbar.

2. <T> to the driveway centerline near the driveway end line and <D> to accept.

3. <T> and  accept to each end of the driveway end line.  The illustration below shows the 
results.

4. From the InRoads menu bar, Select File > Import > Surface.

5. Set up the Import Surface dialog box as in the Setting Elevations (pg. 145) section above, 
using Driveway Edge as the Seed Name.
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6. <D> Apply the <D> on one of the edge lines.  Repeat the process with the other edge line.

7. Close the Import Surface dialog box.

With the driveway edge features added to the surface, the driveway returns can be added.

8. Select Surface > Design Surface > Fillet Feature from the InRoads menu bar.

9. Make the settings as shown in the illustration below.

10. <D> Apply, then move the cursor into the quadrant for the return and <D>.  The return is 
added to the driveway surface.

11. Set the Reference Feature 1 Name to the other driveway edge feature.
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12. Repeat step 10 to create the other driveway return feature.  The illustration below shows 
the results.

13. Close the Fillet Feature dialog box.

14. Save the driveway surface.

Next, the driveway edges from the end of the fillet to the edge of the mainline are trimmed to 
create a smooth cross slope.

15. Verify that the Driveway 254+47.15 Rt surface is active.

16. Select Surface > Edit Surface > Partial Delete from the InRoads menu bar.

17. <D> on a Driveway Edge line and <D> to accept it.

18. move the cursor above the mainline edge of pavement line and <D>.  This sets the partial 
delete to the end of the driveway edge line.
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19. <T> to the end of the fillet on the drive way edge line then <D> to complete the partial 
delete.

20. Repeat steps 17 through 19 for the other edge line.

21. Save the driveway surface.

The final step in creating the driveway edge lines is to join the line and return features to form a 
single feature.  This will make it easier to construct the side slopes for the drive way.

22. Verify that the Driveway 254+47.15 Rt surface is active.

23. Select Surface > Edit Surface > Join Features.

24. <D> on a driveway edge line and <D> to accept.
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25. <D> on the corresponding driveway return and <D> to accept. <R> to exit the Join 
Features command.  The two features are now combined into a single feature.  The name 
for the combined feature is that of the first feature selected.

26. Repeat steps 23 through 25 for the other driveway edge.

27. Save the driveway surface.

This completes the backbone of the driveway.

Section Summary:

The 3D centerline was copied to the ends of the driveway end line, forming the basis of the 
driveway edge lines.  These were imported into the driveway surface.  Fillet feature was used to 
form the driveway returns. Then the edge lines were trimmed back to the ends of the returns.  
Finally, the edges and returns were joined to make a single feature out of each.

Lab 20.4 - Sideslopes and the Exterior Boundary

With the backbone of the driveway complete, the sideslopes and exterior boundary can be added to finish the 
driveway model.

Section Objectives:

 Modify an end condition section to search for a specific surface.

 Use Apply Template to create driveway sideslopes.

 Create an exterior boundary from graphic elements.

The sideslopes for the driveway must tie to two different surfaces, the proposed (SH86) surface 
ot the existing (12345 existing ground) surface.  This is accomplished by modifying the end 
condition section to seek a specific surface then applying the section to the area where that 
surface is sought. 
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1. Turn off the reference file display.  This will make it easier to see the data that is used.

2. Select Modeler > Create Template from the InRoads menu bar.

3. Display the Dynamic Settings dialog box.

4. Set the Steps to 0.10 and toggle off Apply Affixes.

5. Navigate to the 3 - Sections - End Conditions folder in the template library explorer.

6. <R> on the 3 - Sections - End Conditions folder and select New > Folder.

7. Key in Driveway End Conditions for the name.

The next step is to build a new end condition section for the driveway.  It uses components that 
are already in the template library.
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8. <R> on the Driveway End Conditions folder and select New > Template.

9. Key in 4_to_1-Existing for the name.

Now that the template placeholder is built, data can be added to it.  The data for this new 
section comes from the end condition components folders.

10. Navigate to the 4 - Components > End Conditions > Fill Slope Components 
folder.

11. <D> on the Fill_4_to_1 component to display it in the Preview.

12. Drag the component from the Preview into the 4_to_1-Existing section by its origin 
and place it on the origin on the new section.

13. Expand the Cut Slope Components folder and <D> on the Cut_4_to_1 component.

14. Drag and drop this component into the new setion on the origin.

15. Edit the fill component.

16. In the Component Properties dialog box, End Condition Properties area, set the Surface 
to 12345 Existing Ground.
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17. <D> Apply, then Close.

18. Repeat steps 15 and 16 for the cut component.

19. Key in 2 for the Priority of the cut component.

20. <D> Apply, then Close.

21. Save the template library.

This completes the end condition used to tie to the existing surface.  Next, copy this template 
and modify it to seek the design surface.

22. <R> on the 4_to_1-Existing section and select Copy.

23. <R> on the Driveway End Conditions folder and select Paste.

24. Rename the section to 4_to_1-Proposed.

25. <D> <D> on the 4_to_1-Proposed section to make it active.
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26. Edit the component properties as described above, changing the target surface to SH86.

27. Save the template library.

These sections (templates) are used to create the sideslopes on both sides of the driveway.  
They are applied to specific parts of the driveway to target the desired surface in that area.

28. Select Surface > Design Surface > Apply Template from the InRoads menu bar.

29. In the Apply Template dialog box, set the Design Surface to Driveway 254+47.15 Rt.

30. Toggle on Interval and key in 1.00 for the value.

31. Toggle on Stroke Tolerance and key in 0.01 for the value.

32. Navigate to  3 - Sections - End Conditions > Driveway End Conditions in the template 
library.

33. <D> on the 4_to_1-Existing section.

34. Verify that Generate Graphics Only is toggled off.
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35. Toggle on Remove Loops and Triangulate Surface.

36. <D> Apply.

37. Follow the prompts displayed in the lower left corner of the MicroStation window.

38. Select the left driveway edge as the Primary and Reference elements.
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39. At the prompt, “Identify Beginning/Reset for Entire”, Set the MicroStation snap mode to 
Intersection.

40. <T> on the mainline top of cut feature then <T> on the driveway edge feature.

41. Use the keypoint snap to select the end point.

Important! After selecting the location to apply the section, the Apply Template dialog 
box reappears.  However, there is still one more prompt to answer.  Do not 
forget the final <D> to accept the solution.
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The result of the Apply Template is shown below (shown inside the circle).

42. Repeat the Apply Template process, using the 4_to_1-Proposed section, to model the 
sideslope to the (proposed) SH86 surface.  The illustration below shows the results after 
applying both sections to the left side.
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43. In the Apply Template dialog box, toggle on Reflect.
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44. Apply both sections to the right side of the driveway as described above.  The results of all 
of the Apply Template commands are shown below.

The final step for the drive is to create an exterior boundary.  The boundary is defined using the 
graphics of the cut and fill features along with the driveway end feature and the proposed edge 
of pavement from Sh86.  

45. Select the MicroStation Delete command from the Main toolbar.

46. Delete the graphic elements that will not be used for the exterior boundary.  The illustration 
below shows the elements needed.
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To create the boundary, the edge of pavement line needs to be trimmed and the gaps between 
elements need to be filled.

47. In MicroStation, toggle of the Graphic Group lock.

48. Select the Partial Delete command from the MicroStation Main toolbar.

49. Partial delete the edge of pavement lines from where the driveway toes intersect away from 
the driveway.
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50. Select the MicroStation Place Smartline command.  Use this command to fill in the gaps 
between elements.  Be sure to <T> to the ends of the lines.  This will ensure that the 
elements are connected properly.  Not snapping to the lines could result in erroneous 
elevation data.  The gaps filled are illustrated below.

A closed shape element is created from the linework defining the exterior boundary

51. Select the MicroStation Create Complex Shape command.

52. In the toolsettings dialog box, set the Method to Automatic.

53. <D> on an element of the boundary the <D> anywhere.  This creates a closed shape from 
the graphic elements that makeup the exterior boundary.
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Import complex shape into the driveway surface as an exterior boundary, to complete the 
model.

54.  From the InRoads menu bar, select File > Import > Surface.

55. In the Import Surface dialog box, set the Surface to Driveway 254+47.15 Rt.

56.  Set Load From to Single Element.

57. Set Elevations to Use Element Elevations.

58. In the Seed Name field, key in Exterior Boundary.

59. Set the Feature Style to Exterior Boundary.

60. Set the Point Type to Exterior.

61. <D> Apply then <D> on the boundary graphic element.

62. Close the Import Surface dialog box.

63. From the InRoads explorer, <R> on the Driveway 254+47.15 Rt surface and select 
Triangulate.
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64. To evaluate the ramp, creat a single cross section at station 254+47.15.

Below is a rendered view of the driveway

Section Summary:

In this section,  end conditions were developed and applied to the driveway edges to form the 
side slopes.  Features from the driveway surface and the mainline (SH86) surface were 
displayed and used to build the exterior boundary graphically.  This graphic was imported into 
the driveway surface to finish the model.  A cross section was created to review the ramp.
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Chapter Summary:

In this lab, a driveway was designed using a variety of InRoads and MicroStation tools.  From InRoads, the 
following tools were used:

 Tracking

 Create Surface

 Drape Surface

 Generate Longitudinal Feature

  Import Surface from Graphics

 View Features

 Fillet Feature

 Partial Delete (Feature)

 Join Features

 Create Template

 Apply Template

From MicroStation, the following tools were used:

 Place Smartline

 Copy

 Partial Delete (Graphic)

 Delete

 Create Complex Shape


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